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Math Guide

Preface

Who is this book for?
LibreOffice Math is a formula (equation) editor that is an integral part of LibreOffice. Anyone who
wants to learn how to insert formulas and equations using Math will find this guide valuable.
If you have never used LibreOffice Math before, or you want an introduction to all of the
LibreOffice components, you might like to read the LibreOffice Getting Started Guide first.

Where to get more help
This guide, other LibreOffice user guides, the built-in Help system, and user support systems
assume that you are familiar with your computer and basic functions such as starting a program,
opening and saving files.

Help system
LibreOffice comes with an extensive Help system. This is your first line of support for using
LibreOffice. Windows and Linux users can choose to download and install the offline Help for use
when not connected to the Internet; the offline Help is installed with the program on macOS.
To display the full Help system, press F1 or go to Help > LibreOffice Help on the main menu
bar. In addition, you can choose whether to activate Extended tips by going to Tools > Options >
LibreOffice > General on the main menu bar.
You can hover the mouse pointer over any of the icons and a small balloon (tooltip) will pop up
giving a brief explanation of the function for that icon. For a more detailed explanation, select
Help > What's This? on the main menu bar and hover the pointer over the icon.

Free online support
The LibreOffice community not only develops software, but provides free, volunteer-based
support. See Table 1 and this web page: http://www.libreoffice.org/get-help/
Table 1: Free support for LibreOffice users
Ask LibreOffice

Questions and answers from the LibreOffice community
https://ask.libreoffice.org/en/questions/

Documentation

User guides, how-tos, and other documentation.
https://documentation.libreoffice.org/en/
https://wiki.documentfoundation.org/Documentation/Publications

Mailing lists

Free community support is provided by a network of experienced users
https://www.libreoffice.org/get-help/mailing-lists/

FAQs

Answers to frequently asked questions
https://wiki.documentfoundation.org/Faq

International support

Accessibility options

The LibreOffice website in various languages.
https://www.libreoffice.org/community/nlc/
International mailing lists
https://wiki.documentfoundation.org/Local_Mailing_Lists
Information about available accessibility options.
https://www.libreoffice.org/get-help/accessibility/

You can get comprehensive online support from the community through mailing lists and the Ask
LibreOffice website, http://ask.libreoffice.org/en/questions/. Other websites run by users also offer
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free tips and tutorials. This forum provides support for LibreOffice, among other programs:
http://forum.openoffice.org/en/forum/

Paid support and training
You can also pay for support through service contracts from a vendor or consulting firm
specializing in LibreOffice. For information about certified professional support, see The
Document Foundation’s website: https://www.documentfoundation.org/gethelp/support/

What you see may be different
LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several
versions and can be customized by users (fonts, colors, themes, window managers).

Illustrations
The illustrations in this guide were taken from the Windows 10 operating system. Therefore,
some illustrations will not look exactly like what you see on your computer display.
Also, some of the dialogs may be different because of the settings selected in LibreOffice. You
can either use dialogs from your computer system or dialogs provided by LibreOffice. To change
to using LibreOffice dialogs if settings have been altered:
1) Access the general options for LibreOffice as follows:
– On Linux and Windows, go to Tools > Options > LibreOffice > General on the main
menu bar.
– On macOS, go to LibreOffice > Preferences > General on the main menu bar.
2) Select Use LibreOffice dialogs in Open/Save Dialogs to display and use the LibreOffice
dialogs for opening and saving files.
3) For Linux operating systems only, select Use LibreOffice dialogs in Print Dialogs to
display and use the LibreOffice dialogs for printing your documents.
4) Click OK to save your settings and close the dialog.

Note
If you are using a Linux operating system as a virtual machine on a computer
running a Windows or Mac operating system, then the LibreOffice option of using
Print Dialogs is not available.

Icons
The icons used to illustrate some of the many tools available in LibreOffice may differ from the
ones used in this guide. The icons in this guide have been taken from a LibreOffice installation
that has been set to display the default set of icons. If you wish, you can change your LibreOffice
icons as follows:
1)

Access the view options for LibreOffice as follows:
– On Linux and Windows, go to Tools > Options > LibreOffice > View on the main
menu bar.
– On macOS, go to LibreOffice > Preferences > View on the main menu bar.

2)

In Icon Style, select from the options available in the Icon Style drop-down list.
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3)

Click OK to save your settings and close the dialog.

Using LibreOffice on macOS
Some keystrokes and menu items are different on macOS from those used in Windows and
Linux. The table below gives some common substitutions for the instructions in this book. For a
more detailed list, see the application Help.
Windows or Linux

macOS equivalent

Effect

Tools > Options menu

LibreOffice > Preferences

Access setup options

Right-click

Control+click or right-click
depending on computer setup

Open a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F11

⌘+T

Open the Styles deck in the Sidebar
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Chapter 1
Creating & Editing Formulas

Introduction
Math is a formula editor module included with LibreOffice that allows you to create or edit
formulas (equations) in a symbolic form, within LibreOffice documents or as stand-alone objects.
Example formulas are shown below:

df (x)
−1
2
=ln (x)+tan (x ) or NH3 +H2 O ⇌NH+4 +OH −
dx
The Formula Editor in Math uses a markup language to represent formulas. This markup
language is designed to be easily read wherever possible. For example, the statement a over
b using markup language produces the fraction

a
when used in a formula.
b

Keep in mind that that LibreOffice Math is not capable of evaluating mathematical equations or
perform actual calculations. For that purpose you should refer to the Calc Guide.

Getting started
Using the Formula Editor, you can create a formula as a separate document or file for a formula
library, or insert formulas directly into a document using LibreOffice Writer, Calc, Impress, or
Draw.

Formulas as separate documents or files
To create a formula as a separate document or file, use one of the following methods to open an
empty formula document in LibreOffice Math (Figure 1).
•

On the main menu bar, go to File > New > Formula.

•

On the Standard toolbar, click the triangle to the right of the New icon
Formula from the context menu.

•

From the Start Center, click Math Formula.

•

From within LibreOffice Math, use the keyboard shortcut Ctrl+N.

•

You can also launch Math from the command line using libreoffice --math
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and select

Figure 1: An overview of the Math interface to edit a mathematical formula
As you enter the markup language in the Formula Editor, the formula will appear in the Preview
window during and after input of the markup language. The Elements Dock to the left of the
Preview window may also appear, if these have been selected in View on the main menu bar.
Figure 2 illustrates how to enable the Elements dock in Math. For more information on creating
formulas, see “Creating formulas” on page 13.

Figure 2: Enabling the Elements Dock
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Formulas in LibreOffice documents
To insert a formula into a LibreOffice document, open the document in Writer, Calc, Draw, or
Impress. The LibreOffice module you are using affects how you position the cursor to insert the
formula.
•

In Writer, click in the paragraph where you want to insert the formula.

•

In Calc, click in the spreadsheet cell where you want to insert the formula.

•

In Draw and Impress, the formula is inserted into the center of the drawing or slide.

Then, go to Insert > Object > Formula on the main menu bar to open the Formula Editor.
Alternatively, go to Insert > Object > OLE Object on the main menu bar to open the Insert OLE
Object dialog, then select Create new option, choose the Object Type “LibreOffice 7.0 Formula”
and then click OK to open the Formula Editor. The Elements Dock to the left of the Preview
window and/or the Elements dialog as a floating dialog may also appear, if these have been
selected in View on the main menu bar. For more information on creating formulas, see “Creating
formulas” on Page 13.
Figure 3 shows an example Writer document with the formula box selected ready for a formula to
be entered.

Figure 3: Empty formula in a Writer document
When you have completed entering the markup language for your formula, close the Formula
Editor by pressing the Esc key or by clicking an area outside the formula in your document.
Double-clicking on the formula object in your document will open the Formula Editor again so that
you can edit the formula.
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Formulas are inserted as OLE objects into documents. You can, as with any OLE object, change
how the object is placed within your document. For more information on OLE objects, see
Chapter 2 Formulas in Writer, Chapter 3 Formulas in Calc, Draw & Impress and the user guides
for Writer, Calc, Draw, and Impress.
If you frequently insert formulas into documents, it is recommended to add the Formula button to
the Standard toolbar or create a keyboard shortcut. See Chapter 4 Customization for more
information.

Creating formulas
You can create a formula using one of the following methods:
•

In the Elements Dock, select a category from the drop-down list, then a symbol.

•

Right-click in the Formula Editor and select a category, then a symbol from the context
menu.

•

Enter markup language directly in the Formula Editor.

Note
Using the Elements Dock or the context menus to create a formula provides a
convenient way to learn the markup language used by LibreOffice Math.

Tip
When using the Elements Dock, it is recommended to have Extended Tips selected
in the LibreOffice Options. This will help you identify the categories and symbols you
want to use in your formula. Go to Tools > Options on the main menu bar, then
select LibreOffice > General in the Options dialog and select Extended Tips in the
Help section.

Elements Dock
The Elements Dock is a visual tool that will help you create and edit your formula. It organizes
mathematical symbols and operators using Categories in a drop-down list, as seen at the top of
Figure 4. The steps below describe how to enable the Elements Dock and navigate its categories
and symbols.
1) Go to View on the main menu bar and select Elements Dock to enable the Elements
Dock.
2) Select the category you want to use in your formula from the drop-down list at the top of
the Elements Dock.
3) Select the symbol you want to use in your formula from the Elements Dock. The symbols
that are available change according to the selected category.
4) After choosing one of the symbols in the Elements Dock, the Formula Editor will be
updated with the Markup notation of the selected symbol.
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Figure 4: Elements Dock

Note
The Elements Dock can either be a floating dialog, as shown in Figure 4, or
positioned to the left of the Formula Editor, as shown in Figure 1 and Figure 3.

Tip
The Elements Dock also provides an Examples category which gives you example
formulas to use as a starting point for your formula or equation.

Context menu
The Formula Editor also provides a context menu to access categories and symbols when
creating your formula. Right-click in the Formula Editor to open the context menu. Select a
category and then select the markup example that you want to use from the sub-context menu,
an example is shown in Figure 5.

Note
The Elements Dock and the Context Menu only contain the most common
commands that are used in formulas. To insert other symbols and commands not
listed in the Elements Dock and Context Menu, you will have to enter them manually
using the markup language. For a complete list of commands and symbols available
in Math, see Appendix A Commands Reference.
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Figure 5: Context menu in Formula Editor

Markup language
Markup language is entered directly into the Formula Editor. For example, typing the markup
language 5 times 4 into the Formula Editor creates the simple formula 5×4 . If you are
experienced in using markup language, it can be the quickest way to enter a formula. Table 2
shows some examples of using markup language to enter commands. For a full list of commands
that can be used in the Formula Editor, see Appendix A Commands Reference.
Table 2: Example commands using markup language
Formula
Markup Notation
Formula

a=b

Markup Notation

a = b

√a

sqrt {a}

a^2

an

a_n

∫ f ( x)dx

int f(x) dx

∑ an

sum a_n

a≤b

a <= b

∞

infinity

a×b

a times b

x⋅y

x cdot y

a

2
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Greek characters
Using markup language
Greek characters are commonly used in formulas, but Greek characters cannot be entered into a
formula using the Elements Dock or the context menu. Use the English names of Greek
characters in markup language when entering Greek characters into a formula. See Appendix A
Commands Reference for a list of Greek characters that can be entered using markup language.
•

For a lowercase Greek character, type a percentage % sign, then type the character
name in lowercase using the English name. For example, typing %lambda creates the
Greek character λ .

•

For an UPPERCASE Greek character, type a percentage % sign, then type the character
name in UPPERCASE using the English name. For example, typing %LAMBDA creates
the Greek character Λ.

•

For an italic Greek character, type a percentage % sign followed by the i character, then
the English name of the Greek character in lower or UPPER case. For example, typing
%iTHETA creates the italic Greek character Θ .

Symbols dialog
Greek characters can also be entered into a formula using the Symbols dialog.
1) Make sure your cursor is in the correct position in the Formula Editor.
2) Go to Tools > Symbols on the main menu, click the toolbar Symbols icon
Symbols dialog (Figure 6)

to open the

3) Select Greek from the Symbol set drop-down list. For italic characters, select iGreek
from the drop-down list.
4) Select the Greek character from the symbol list, then click Insert. When selected, the
name of a Greek character is shown below the symbol list.
5) Click Close when you have finished entering Greek characters into your formula.

Figure 6: Symbols dialog
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Formula examples
Example 1
The simple formula 5×4 can be created using LibreOffice Math as follows:
1) Make sure your cursor is flashing in the Formula Editor, then select the category
Unary/Binary Operators and symbol Multiplication using one of the following methods:
– In the Elements Dock, select Unary/Binary Operators from the drop-down list and
then select the Multiplication icon
.
– Right-click in the Formula Editor and select Unary/Binary Operators > a times b
from the context menu.
– The first two methods place the formula text <?> times <?> in the Formula Editor
and the symbol
appears in the document.
– Using markup language in the Formula Editor, type 5 times 4 in the Formula Editor
to create the formula 5×4 directly into your document; in this case there is no need
to carry out the following steps.
2) Select the first placeholder <?> before the word times in the Formula Editor and replace
it with the character 5. The formula in your document updates automatically.
3) Select the second placeholder <?> after the word times in the Formula Editor and
replace it with the character 4. The formula in your document updates automatically.

Tip
To move forward from one placeholder to the next placeholder in a formula, press
the F4 key. To move backward from one placeholder to the previous placeholder in a
formula, use the key combination Shift+F4.

Note
If necessary, you can prevent a formula in a document from updating automatically.
Go to View on the main menu bar and deselect AutoUpdate Display. To manually
update a formula, press F9 key or select View > Update on the main menu bar.

Example 2
You want to enter the formula π ≃ 3.14159 where the value of pi is rounded to 5 decimal places.
You know the name of the Greek character (pi), but do not know the markup associated with the
Is Similar Or Equal symbol ≃ .
1) Make sure your cursor is flashing in the Formula Editor.
2) Enter %pi in the Formula Editor to enter the Greek character for pi (π).
3) Select the category Relations and symbol Is Similar Or Equal using one of the following
methods:
– In the Elements Dock, select Relations from the drop-down list and then select the Is
Similar Or Equal icon
.
– Right-click in the Formula Editor and select Relations > a simeq b from the context
menu.
4) Delete the first placeholder <?> before the word simeq in the Formula Editor.
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5) Select the second placeholder <?> after the word simeq in the Formula Editor and
replace it with the characters 3.14159. The formula π ≃ 3.14159 now appears in
your document.

Editing formulas
How you edit a formula and switch into formula editing mode depends on whether the formula is
in Math or another LibreOffice module.
1) In Math, double-click on a formula element in the formula that appears in the Preview
window to select the formula element in the Formula Editor, or directly select a formula
element in the Formula Editor.
2) In Writer, Calc, Impress, or Draw, double-click on the formula, or right-click on the formula
and select Edit form the context menu, to open the Formula Editor and enter editing
mode. The cursor is positioned at the start of the formula in the Formula Editor.

Note
If you cannot select a formula element using your cursor, click on the Formula
Cursor icon
in the Tools toolbar to activate the formula cursor.
3) Select the formula element you want to change using one of the following methods:
– Click on the formula element in the preview window, positioning the cursor at the
beginning of the formula element in the Formula Editor, then select the formula
element in the Formula Editor.
– Double-click on the formula element in the preview window to select the formula
element in the Formula Editor.
– Position the cursor in the Formula Editor at the formula element you want to edit, then
select that formula element.
– Double-click directly on the formula element in the Formula Editor to select it.
4) Make your changes to the formula element you have selected.
5) Go to View > Update on the main menu bar, or press the F9 key, or click on the Update
icon
on the Tools toolbar to update the formula in the preview window or your
document.
6) In Math, save your changes to the formula after editing.
7) In Writer, Calc, Impress, or Draw, click anywhere in your document away from the formula
to leave editing mode, then save your document to save your changes to the formula.

Formula layout
This section provides some advice on how to layout complex formulas in Math or in your
LibreOffice document.

Using braces
LibreOffice Math knows nothing about order of operation within a formula. You must use braces
(curly brackets) to state the order of operations that occur within a formula. The following
examples show how braces can be used in a formula.
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Example 1
2 over x + 1 gives the result

2
+1
x

Math has recognized that the 2 before and the x after the over command as belonging to
the fraction, and has represented them accordingly. If you want x+1 rather than x to be the
denominator, you must bracket them together using braces so that both will be placed
there.
Inserting braces into 2 over {x + 1} gives the result

2
where x +1 is now the
x+1

denominator.

Example 2
– 1 over 2 gives the result

−1
2

Math has recognized the minus sign as a prefix for the 1 and has therefore placed it in the
numerator of the fraction. If you wish to show that the whole fraction is negative, with the
minus sign in front of the fraction, you must put the fraction in braces to signify to Math that
the characters belong together.
Adding braces into the markup language – {1 over 2} gives the result –

1
and the
2

whole fraction is now negative.

Example 3
When braces are used in markup language, they are used to define the layout of the
formula and are not displayed or printed. If you want to use braces within a formula, use
the commands lbrace and rbrace within the markup language.
x over {–x + 1} gives the result

x
– x+1

Replace the braces using the commands lbrace and rbrace in the markup language.
Write x over lbrace –x + 1 rbrace and the result is

x
{– x +1}

Brackets (parentheses) and matrices
If you want to use a matrix in a formula, you have to use the matrix command. Below is a
simple example of a 2 x 2 matrix.
matrix { a # b ## c # d }

a b
c d

In matrices, rows are separated by two hashes (##) and entries within each row are separated by
one hash (#).
Normally, when you use brackets within a matrix, the brackets do not scale as the matrix
increases in size. The example below shows an a formula where the parentheses do not scale to
the size of the resulting matrix.
( matrix { a # b ## c # d } )

(

a b
)
c d
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To overcome this problem of brackets in a matrix, LibreOffice Math provides scalable brackets
that grow in size to match the size of the matrix. The commands left( and right) have to be
used to create scalable brackets around a matrix. The following example shows how to create a
matrix with scalable parentheses.

(ac bd )

left( matrix { a # b ## c # d } right)

Scalable brackets can also be used with any element of a formula, such as fraction, square root,
and so on.
If you want to create a matrix where some values are empty, you can use the grave accent (`) so
that Math will put a small space in that position, as shown in the example below:
left( matrix { 1 # 2 # 3 ##
4 # ` # 6 } right)

( 14

2 3
6

)

Tip
Use the commands left[ and right] to obtain square brackets. A list of all
brackets available within Math can be found in Appendix A Commands Reference.

Tip
If you want all brackets to be scalable, go to Format > Spacing to open the Spacing
dialog. Click on Category, select Brackets from the drop-down list and then select
the option Scale all brackets.

Unpaired brackets
When using brackets in a formula, Math expects that for every opening bracket there will be a
closing one. If you forget to add a closing bracket, Math places an inverted question mark next to
where the closing bracket should have been placed. For example, lbrace a; b will result in
¿ because the right bracket rbrace is missing.
This inverted question mark disappears when all the brackets are paired. The previous example
could be fixed to lbrace a; b rbrace, resulting in {a ; b}. However, there are cases where an
unpaired bracket is necessary and for that you have the following options.

Non scalable brackets
A backslash \ is placed before a non scalable bracket to indicate that the subsequent character
should not be regarded as a bracket, but rather as a literal character.
For example, the unpaired brackets in the formula [ a; b [ would result in an inverted
question mark because Math expects that [ will be closed by ]. To fix the error you can use the
backslash and insert \ [ a; b \ [ into the Formula Editor to obtain [a ; b [ as the result.

Scalable brackets
To create unpaired scalable brackets or braces in a formula, the markup commands left,
right, and none can be used.
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Example
The following formula uses the stack command to create a two-line formula and adds a
bracket only to the right side of the stack.

|x|= x for x≥0
−x for x <0

abs x = left lbrace stack {x "for" x
>= 0 # -x "for" x < 0} right none

{

This effect can be achieved by using the left lbrace command combined with the
right none command. The first command indicates that the left bracket is a lbrace
whereas the second command tells Math that the right bracket will be none, meaning that
no bracket will be added to the right side of the formula.

Recognizing functions
In the basic installation of Math, Math outputs functions in normal characters and variables in
italic characters. However, if Math fails to recognize a function, you can tell Math that you have
just entered a function. This is done by adding the markup command func before a function to
force Math to recognize the subsequent text as a function.
For a full list of functions within Math, see Appendix A Commands Reference.
Some Math functions have to be followed by a number or a variable. If these are missing, Math
places an inverted question mark where the missing number or variable should be. To remove
the inverted question mark and correct the formula, you have to enter a number, a variable, or a
pair of empty brackets as a placeholder.

Tip
You can navigate through errors in a formula using the key F3 to move to the next
error or the key combination Shift+F3 to move to the previous error.

Formulas over multiple lines
Suppose you want to create a formula that requires more than one line, for example x=3 .

y=1

Your first reaction would normally be to press the Enter key. However, if you press the Enter key,
the markup language in the Formula Editor goes to a new line, but the resulting formula does not
have two lines. To add a new line to the formula you need to use the markup command
newline.

Example
The examples below illustrate how the markup command newline can be used to add a
new line to a formula. The first one simply adds an Enter to break the line in the markup
language, which does not result in adding a new line. The second example uses the
newline command, yielding a two-line formula.
Markup Language

Resulting Formula

x = 3
y = 1

x=3 y=1

x = 3 newline y = 1

x=3
y=1
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It is not possible in Math to create multiple line formulas when a line ends with an equals
sign and you want to continue the formula on a new line without completing the term on the
right side of the equals sign. If you require a multiple line formula to have an equals sign at
the end of a line without a term after the equals sign, then use either empty quotes “” or
empty braces {} or the space characters grave ` or tilde ˜.
By default, the alignment of a multiple line formula is center aligned. For more information on
alignment using the equals sign, see Chapter 4 Customization.

Spacing within formulas
Spacing between the element in a formula is not set by using space characters in the markup
language. If you want to add spaces into your formula, use one of the following options:
•

Grave ` to add a small space.

•

Tilde ~ for a large space.

•

Add space characters between quotes “ ”. These spaces will be considered as text.

Any spaces at the end of a line in the markup language are ignored by default. For more
information, see Chapter 4 Customization.

Adding limits to summations and integrals
The sum and int commands, used for summations and integrals respectively, can take the
parameters from and to if you want to set the lower and upper limits. The parameters from and
to can be used singly or together as shown by the following examples. For more information on
the sum and integral commands, see Appendix A Commands Reference.

Examples
Next you’ll find some examples of how to add upper and lower bounds to summations and
integrals. Note that you can use brackets to explicit define which parts of the formula
correspond to the desired bounds.
Markup Language

Resulting Formula
n

sum from k = 1 to n a_k

∑ ak
k=1
∞

sum to infinity 2^{-n}
sum from{ i=1 } to{ n } sum
from{ j=1; i <> j } to{ m } x_ij

∑ 2−n
n

m

∑ ∑

i=1 j=1 ;i≠ j

x ij

x

int from 0 to x f(t) dt

∫ f (t)dt
0

x

int_0^x f(t) dt

∫0 f (t)dt

int from Re f

∫ℜ f
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Writing derivatives
When writing derivatives, you have to tell Math that it is a fraction by using the over command.
The over command is combined with the character d for a total derivative or the partial
command for a partial derivative to achieve the effect of a derivative. Braces {} are used in each
side of the elements to surround them and make the derivative as shown by the following
examples.

Examples
Below are a few examples of how you can use Math to write derivatives:
Markup Language

Resulting Formula

{df} over {dx}

df
dx

{partial f} over {partial y}

∂f
∂y

{partial^2 f} over {partial t^2}

∂ f
2
∂t

2

Note
To write function names with primes, as is normal in school notation, you must first
add the symbols to the catalog. See Chapter 4 Customization for more information.

Markup language characters as normal characters
Characters that are used as controls in markup language cannot be entered directly as normal
characters. These characters are: %, {, }, &, |, _, ^ and ". For example, you cannot write
2% = 0.02 in markup language and expect the same characters to appear in your formula. To
overcome this limitation in markup language, use one of the following methods:
•

Use double quotes to mark that character as text, for example 2"%"= 0.02 will appear
in your formula as 2 %=0.02 . However, this method cannot be used for the doublequote character itself, see “Text in formulas” below.

•

Add the character to the Math Catalog, for example the double quote character.

•

Use commands, for example lbrace and rbrace give you literal braces {} .

Note
The Special Characters dialog used by other LibreOffice modules is not available in
Math. If you are going to regularly require special characters in Math, then it is
recommended to add the characters to the Math Catalog, see Chapter 4
Customization for more information.
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Text in formulas
To include text in a formula, you have to enclose any text in double-quotes, for example x "
for " x >= 0 in markup language will create the formula x for x≥0 . All characters, except
double quotes, can be used in text.
However, if you require double quotes in your formula text, then you have to create your text with
double quotes in LibreOffice Writer, then copy and paste the text into the Formula Editor as
shown in Figure 7.
The font used for text in a formula will be the default font that has been set in the Fonts dialog.
For more information on how to change fonts used for in formulas, see “Changing formula
appearance” on page 25.
By default, text alignment is left-justified in formulas. For more information on how to change text
alignment, see “Adjusting formula alignment” on page 31.

Figure 7: Example of double quotes in formula text

Formatting text in formulas
Formatting commands are not interpreted within text used in formulas. If you want to use
formatting commands within formula text, then you must break up the text using double quotes in
the Formula Editor.

Example
Enter the following in the Formula Editor:
"In " color blue bold "isosceles" "triangles, the base angles are
equal"
creates the following text in a formula In isosceles triangles, the base angles are equal .
This example shows how to use the markup commands color and bold to format the
word “isosceles”. Note that the commands are applied to the immediately subsequent text
within double quotes. Hence, the formatting commands do not apply to the remainder of
the text in the example because it is in a separate quote block.
The command color needs to be followed by the name of the desired color. You can refer to
Appendix A Commands Reference for a full list of predefined color names.

Aligning formulas using equals sign
LibreOffice Math does not have a command for aligning formulas on a particular character.
However, you can use a matrix to align formulas on a character and this character is normally the

24 | LibreOffice Math Guide Version 7.0

equals sign (=). In addition, you can use the markup commands alignr, alignl and alignc
to set the alignment of each value inside the matrix to the right, left or center, respectively.

Example
Below is an example that uses a matrix to align formulas on the equals sign. Notice how
the alignment commands align the contents of each position in the matrix.
matrix{ alignr x+y # {}={} # alignl 2
## alignr x # {}={} # alignl 2-y }

x+ y
x

= 2
= 2− y

Note
The empty braces each side of the equals sign are necessary because the equals
sign is a binary operator and requires an expression on each side. You can use
spaces, or ` or ~ characters each side of the equals sign, but braces are
recommended as they are easier to see within the markup language.
You can reduce the spacing on each side of the equals sign if you change the inter-column
spacing of the matrix. See “Adjusting formula spacing” on page 29 for information on how to
adjust adjust formula spacing.

Changing formula appearance
Formula font size
Current formula font size
To change the font size used for a formula already inserted in Math or another LibreOffice
module:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Font size on the main menu bar to open the Font Sizes dialog (Figure
8).
3) Select a different font size using the Base size spinner or type a new font size in the Base
Size box.
4) Click OK to save your changes and close the dialog. An example result when you change
font size is shown below.

Example
Default font size 12pt: π ≃ 3.14159
After font size change to 18pt:

π ≃ 3.14159
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Figure 8: Font Sizes dialog

Default formula font size
To change the default font size used for all formulas in Math or another LibreOffice module:
1)

Before inserting any formulas in your document, go to Format > Font size on the main
menu bar to open the Font Sizes dialog (Figure 8).

2)

Select a different font size using the Base size spinner or type a new font size in the Base
Size box.

3)

Click Default and confirm your changes to the base size font. Any formulas created from
this point on will use the new base size font for formulas.

4)

Click OK to save your changes and close the Font Sizes dialog.

Note
If you have already inserted formulas into your document and you change the default
font size, only formulas inserted after the change in default font size will use the new
default settings. You have to individually change the font size of formulas already
inserted if you want these formulas to use the same font size as the default settings.

Tip
There is an extension “Formatting of all Math formulas”. It allows to change font
name and font size for all or only for selected formulas in your document. You can
download it and read the installation and usage instructions in extension’ official
website: https://extensions.libreoffice.org/extensions/formatting-of-all-math-formulas

Font size options
The Font Sizes dialog (Figure 8) specifies the font sizes for your formula. Select a base size and
all elements of the formula will be scaled in relation to this base.
•

Base size – all elements of a formula are proportionally scaled to the base size. To
change the base size, select or type in the desired point (pt) size. You can also use other
units of measure or other metrics, which are then automatically converted to points.

•

Relative Sizes – in this section, you can determine the relative sizes for each type of
element with reference to the base size.
– Text – select the size for text in a formula relative to the base size.
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– Indexes – select the relative size for the indexes in a formula in proportion to the base
size.
– Functions – select the relative size for names and other function elements in a formula
in proportion to the base size.
– Operators – select the relative size of the mathematical operators in a formula in
proportion to the base size.
– Limits – select the relative size for the limits in a formula in proportion to the base size.
This is used to determine the size for commands as from and to used in summations
and integrals.
•

Default – clicking this button saves any changes as a default for all new formulas. A
confirmation message appears before saving any changes.

Formula fonts
Current formula fonts
To change the fonts used for the current formula in Math or another LibreOffice module:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Fonts on the main menu bar to open the Fonts dialog (Figure 9).
3) Select a new font for each of the various options from the drop-down lists.
4) If the font you want to use does not appear in the drop-down list, click Modify and select
the option from the context menu to open a fonts dialog. Select the font you want to use
and click OK to add it to the drop-down list for that option.
5) Click OK to save your changes and close the Fonts dialog.

Figure 9: Fonts dialog

Default formula fonts
To change the default fonts used for all formulas in Math or another LibreOffice module:
1)

Before inserting any formulas in your document, go to Format > Fonts on the main menu
bar to open the Fonts dialog (Figure 9).

2)

Select a new font for each the various options from the drop-down lists.
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3)

If the font you want to use does not appear in the drop-down list, click Modify and select
the option from the context menu to open a fonts dialog. Select the font you want to use
and click OK to add it to the drop-down list for that option.

4)

Click Default and confirm your changes to the fonts. Any formulas created from this point
on will use the new font for formulas.

5)

Click OK to save your changes and close the Fonts dialog.

Note
If you have already inserted formulas into your document and you change the default
fonts, only formulas inserted after the change in default fonts will use the new default
settings. You have to individually change the font of formulas already inserted if you
want these formulas to use the same font as the default settings.

Tip
The extension “Formatting of all Math formulas” can also be used to change the
fonts of all formulas in a document. However, keep in mind that the font selected in
this extension will be applied to Variables, Functions, Numbers and Text. To
download the extension, visit: https://extensions.libreoffice.org/extensions/formattingof-all-math-formulas

Formula font options
Defines the fonts that can be applied to formula elements.
•

Formula Fonts – defines the fonts used for the variables, functions, numbers and
inserted text that form the elements of a formula.
– Variables – selects the fonts for the variables in your formula. For example, in the
formula x=SIN(y), x and y are variables and will reflect the assigned font.
– Functions – selects the fonts for names and properties of functions. For example, the
functions in the formula x=SIN(y) are =SIN( ).
– Numbers – selects the fonts for the numbers in a formula.
– Text – defines the fonts for the text in a formula.

•

Custom Fonts – this section of the Fonts dialog (Figure 9) defines fonts to format text
components in a formula. The three basic fonts Serif, Sans-serif and Fixed-width are
available. Other fonts can be added to each standard installed basic font using the
Modify button. Every font installed on a computer system is available for use.
– Serif – specifies the font to be used for the font serif format. Serifs are the small
"guides" that can be seen, for example, at the bottom of a capital A when the Times
serif font is used. Using serifs is quite helpful since it guides the eye of a reader in a
straight line and can speed up reading.
– Sans – specifies the font to be used for sans font formatting.
– Fixed – specifies the font to be used for fixed font formatting.

•

Modify – click one of the options from the context menu to access the Fonts dialog,
where the font and attributes can be defined for the respective formula and for custom
fonts.

•

Default – clicking this button saves any changes as a default for all new formulas. A
confirmation message appears before saving any changes.
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Note
When a new font is selected for a formula, the old font remains in the list alongside
the new one and can be selected again.

Note
Variables should be written in italics, so make sure that the Italic option is selected.
For the font you want to use. For all other elements, use the basic form of a font. The
style can be easily altered in the formula itself by using the commands italic or
bold to set these characteristics and nitalic or nbold to unset them.

Adjusting formula spacing
Use the Spacing dialog (Figure 10) to determine the spacing between formula elements. The
spacing is specified as a percentage in relation to the defined base size for font sizes.

Figure 10: Spacing dialog

Current formula spacing
To change the spacing used for the current formula in Math or another LibreOffice module:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Spacing on the main menu bar to open the Spacing dialog (Figure 10).
3) Click Category and select one of the options from the drop-down list. The options in the
Spacing dialog change according to the category selected.
4) Enter new values for the spacing category and click OK.
5) Check the result in your formula. If not to your satisfaction, repeat the above steps.

Default formula spacing
To change the default spacing used for all formulas in Math or another LibreOffice module:
1)

Before inserting any formulas in your document, go to Format > Spacing on the main
menu bar to open the Spacing dialog (Figure 10).

2)

Click Category and select one of the options from the drop-down list. The options in the
Spacing dialog change according to the category selected.

3)

Click Default and confirm your changes to the formula spacing. Any formulas created
from this point on will use the new spacing for formulas.

4)

Click OK to save your changes and close the Spacing dialog.
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Note
If you have already inserted formulas into your document and you change the
spacing, only formulas inserted after the change in spacing will use the new default
settings. You have to individually change the spacing of formulas already inserted if
you want these formulas to use the same spacing as the default settings.

Spacing options
Use Category in the Spacing dialog (Figure 10) to determine the formula element for which you
would like to specify the spacing. The appearance of the dialog depends on the selected
category. A preview window shows you which spacing is modified through the respective boxes.
•

Category – pressing this button allows you to select the category for which you would
like to change the spacing.

•

Spacing – defines the spacing between variables and operators, between lines, and
between root signs and radicals.
– Spacing – determines the spacing between variables and operators
– Line Spacing – determines the spacing between lines.
– Root Spacing – determines the spacing between the root sign and radicals.

•

Indexes – defines the spacing for superscript and subscript indexes.
– Superscript – determines the spacing for superscript indexes.
– Subscript – determines the spacing for subscript indexes.

•

Fractions – defines the spacing between the fraction bar and the numerator or
denominator.
– Numerator – determines the spacing between the fraction bar and the numerator.
– Denominator – determines the spacing between the fraction bar and the denominator.

•

Fraction Bars – defines the excess length and line weight of the fraction bar.
– Excess length – determines the excess length of the fraction line.
– Weight – determines the weight of the fraction line.

•

Limits – defines the spacing between the sum symbol and the limit conditions.
– Upper limit – determines the spacing between the sum symbol and the upper limit.
– Lower limit – determines the spacing between the sum symbol and the lower limit.

•

Brackets – defines the spacing between brackets and the content.
– Excess size (left/right) – determines the vertical distance between the upper edge of
the contents and the upper end of the brackets.
– Spacing – determines the horizontal distance between the contents and the upper end
of the brackets.
– Scale all brackets – scales all types of brackets. If you then enter ( a over b) in
the Formula Editor, the brackets will surround the whole height of the argument. You
normally achieve this effect by entering left ( a over b right ).
– Excess size – adjusts the percentage excess size. At 0% the brackets are set so that
they surround the argument at the same height. The higher the entered value is, the
larger the vertical gap between the contents of the brackets and the external border of
the brackets. The field can only be used in combination with Scale all brackets.

•

Matrices – defines the relative spacing for the elements in a matrix.
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– Line spacing – determines the spacing between matrix elements in a row.
– Column spacing – determines the spacing between matrix elements in a column.
•

Symbols – defines the spacing of symbols in relation to variables
– Primary height – defines the height of the symbols in relation to the baseline.
– Minimum spacing – determines the minimum distance between a symbol and
variable.

•

Operators – defines the spacing between operators and variables or numbers.
– Excess size – determines the height from the variable to the operator upper edge.
– Spacing – determines the horizontal distance between operators and variables.

•

Borders – adds a border to a formula. This option is particularly useful if you want to
integrate the formula into a text file in LibreOffice Writer by combining mathematical
formulas and text inside the same paragraph.
– Left – the left border is positioned between the formula and background.
– Right – the right border is positioned between the formula and background.
– Top – the top border is positioned between the formula and background.
– Bottom – the bottom border is positioned between the formula and background.

•

Preview Field – displays a preview of the current selection.

•

Default – saves any changes as default settings for all new formulas. A security
response will appear before saving these changes.

Note
If you are adding Math formulas into a LibreOffice Writer document, you may notice
spacing between the formula and the surrounding text even if you set all formula
borders to zero. This is because Math formulas are OLE objects embedded into a
frame that, by default adds 0.2 cm to the left and right of the Math object. If you want
to remove that extra spacing you have two options. The first is to edit the object
properties by right-clicking the Math object and then going to Properties > Wrap and
adjust the Spacing fields to the desired values. The second option is to modify the
spacing options of the default Formula Frame Style or create a new one from
scratch. To learn more on how to change the spacing of Math objects refer to the
Object spacing section in this guide. For more information on how to edit styles in
general, refer to the Styles chapters in the Writer Guide.

Example
In the following example, Math objects are combined with text by removing all spacing both
from the formula and the frame style surrounding it. Because spacing is set to zero, the
spacing between text and formulas is achieved by simply adding a space character using
the keyboard space bar.
“Let c ij be a cost matrix and x ij ∈{0 ; 1 } be a decision variable defined for i=1,2 , ..., m
origins and for j=1,2 ,... , n destinations”.

Adjusting formula alignment
The alignment settings determine how formula elements located above one another are aligned
horizontally relative to each other.
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Note
It is not possible to align formulas on a particular character and formula alignment
does not apply to text elements. Text elements are always aligned to the left.

Current formula alignment
To change the alignment used for the current formula in Math or another LibreOffice module:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Alignment on the main menu bar to open the Alignment dialog (Figure
11).
3) Select either Left, Centered, or Right for horizontal alignment.
4) Click OK and check the result in your formula. If not to your satisfaction, repeat the above
steps.

Figure 11: Alignment dialog

Note
Regardless of the alignment option selected in the Alignment Dialog, it is possible to
align sections of a formula using the commands alignl, alignc and alignr. For
example, they can be useful to align formulas in matrices. These commands also
work for text elements.

Default formula alignment
To change the default alignment used for all formulas in Math or another LibreOffice module:
1)

Before inserting any formulas in your document, go to Format > Alignment on the main
menu bar to open the Alignment dialog (Figure 11).

2)

Select either Left, Centered, or Right for horizontal alignment.

3)

Click Default and confirm your changes to the formula alignment. Any formulas created
from this point on will use the new alignment for formulas.

4)

Click OK and check the result in your formula. If not to your satisfaction, repeat the above
steps.
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Note
If you have already inserted formulas into your document and you change the
formula alignment, only formulas inserted after the change in alignment will use the
new default settings. You have to individually change the alignment of formulas
already inserted if you want these formulas to use the same alignment as the default
settings.

Changing formula color
Character color
Formula color for the characters used in a formula is changed by using the command color in the
mark up language. This command only works on the formula element immediately after the color
name. For example, entering the markup language color red 5 times 4 gives the result
5×4 . Note that only the number 5 was colored red.
To change the color of the whole formula, you have to enclose the whole formula within brackets.
For example, entering the markup language color red {5 times 4} gives the result 5×4 .
For information on the colors available in Math, see Appendix A Commands Reference.

Applying colors using RGB values
Alternatively, it is possible to use custom colors defined using RGB (Red, Green and Blue) values
ranging from 0 to 255. This is done by using the color rgb R G B markup command, where
R, G and B correspond to the Red, Green and Blue values of the desired color.

Example
Below is an example where the term “decision variable” uses the color sienna, which is
defined by the RGB values 160, 82 and 45.
"Let " x_ij " be a " color rgb 160 82 45 "decision variable " "in
the problem under consideration"
Math will create the following output:

Let x ij be a decision variable in the problem under consideration

Note
RGB colors are used in many functions of all LibreOffice applications. For example,
you can use RGB values to set the text color in LibreOffice Writer. To do that, select
the text you want to change the color then right-click the selection. In the context
menu, go to Character > Font Effects and in the Font Color drop-down list choose
Custom Color. There you will be able to set the text color using RGB values.

Background color
It is not possible to select a background color for formulas in LibreOffice Math. The background
color for a formula is by default the same color as the document or frame that the formula has
been inserted into. In LibreOffice documents, you can use object properties to change the
background color for a formula. For more information read the section Background and borders
in this guide.
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Formula library
If you regularly insert the same formulas into your documents, you can create a formula library
using formulas that you have created using the Formula Editor. Individual formulas can be saved
as separate files using the ODF format for formulas with the file suffix of .odf, or in MathML
format with the file suffix of .mml.
You can use either LibreOffice Math, Writer, Calc, Draw, or Impress to create formulas and build
up your formula library.

Using Math
1) Create a folder on your computer to contain your formulas and give the folder a
memorable name, for example Formula Library.
2) In LibreOffice, go to File > New > Formula on the main menu bar, or click on Math
Formula in the opening splash screen to open LibreOffice Math and create your formula
using the Formula Editor. See “Formulas as separate documents or files” on Page 10 for
more information.
3) Go to File > Save As on the main main menu bar or use the keyboard shortcut
Ctrl+Shift+S to open a Save As dialog.
4) Navigate to the folder you have created for your formula library.
5) Type in a memorable name for your formula in the File name text box.
6) Select from the drop-down list for File type either ODF Formula (.odf) or MathML 2.0
(.mml) as the file type for your formula.
7) Click Save to save your formula and close the Save As dialog.

Note
MathML 2.0 stands for Mathematical Markup Language (MathML) Version 2.0.
MathML is an XML format that describes mathematical notation and enables the use
of mathematics in the World Wide Web. If you want to learn more about the MathML
format, visit its official website at https://www.w3.org/TR/MathML2/overview.html

Using Writer, Calc, Draw, or Impress
1) Create a folder on your computer to contain your formulas and give the folder a
memorable name, for example Formula Library.
2) Open a document using Writer, Calc, Draw, or Impress.
3) Go to Insert > Object > Formula on the main menu bar to open the Formula Editor and
create your formula. See “Formulas in LibreOffice documents” on page 12 for more
information.
4) Right-click on your formula object and select Save Copy as from the context menu to
open a Save As dialog.
5) Navigate to the folder you have created for your formula library.
6) Type in a memorable name for your formula in the File name text box.
7) Select from the drop-down list for File type either ODF Formula (.odf) or MathML 2.0
(.mml) as the file type for your formula.
8) Click Save to save your formula and close the Save As dialog.
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Using your formula library
You cannot insert a formula from your library into a document by dragging and dropping using the
mouse, nor by using Insert > File on the main menu bar. You must insert a formula from your
library into your document as an OLE object.
1) Open your document in Writer, Calc, Draw, or Impress.
2) Go to Insert > Object > OLE Object on the main menu bar to open the Insert OLE
Object dialog.
3) Select the option Create from file.
4) Click Search to open your file browser dialog.
5) Navigate to the folder you have created for your formula library.
6) Select the formula you want to insert and click Open, or double-click on the formula you
want to insert.
7) Click OK to insert your formula as an OLE object in your document and close the OLE
Object dialog.
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Math Guide

Chapter 2
Formulas in Writer

Introduction
When a formula is inserted into a document, LibreOffice Writer inserts the formula into a frame
and treats the formula as an OLE object. Double-clicking on an inserted formula will open the
Formula Editor in LibreOffice Math allowing you to edit the formula. For more information on
creating and editing formulas, please refer to Chapter 1 Creating & Editing Formulas.
This chapter explains what options you can change for each individual formula within your Writer
document. Please refer to the chapters on styles in the Writer Guide for information on how to
change the default settings for frame styles for OLE objects.

Automatic formula numbering
Automatic numbering of formulas for cross reference purposes can only be carried out in
LibreOffice Writer. The easiest way to add numbered formulas in sequence is to use the AutoText
entry fn (for 'formula numbered').

Numbering
1) Start a new line in your document.
2) Type fn and then press the F3 key. A two column table with no borders is inserted into
your document with the left column containing a sample formula and the right column
containing a reference number, as shown below.

E=mc

2

(1)

3) Delete the sample formula and insert your formula as an object in the left column. See
Chapter 1 Creating & Editing Formulas for more information on inserting formulas.
4) Alternatively, you can first insert your formula into the document, then carry out Steps 1
and 2 above replacing the sample formula with your formula.

Cross referencing
1)

Click in your document where you want the cross reference to appear.

2)

Go to Insert > Cross-reference on the menu bar to open the Fields dialog (Figure 12).

3)

Click on the Cross-references tab, then select Text in the Type section.

4)

In the Selection section, select the formula number you want to refer to.

5)

In the Insert reference to section, select Reference and click Insert.

6)

When you have finished creating cross references, click Close to close the Fields dialog.

Tip
To insert the cross reference number without parentheses, select Numbering instead
of Reference in the Insert reference to section.

Note
If you want to use square parentheses instead of round ones, or if you want the
cross reference number to be separated from the formula by tabs instead of using a
table, then refer to the chapter on automatic text in the Writer Guide.

Chapter 2 Formulas in Writer | 37

Figure 12: Fields Dialog – Cross References Page

Anchoring formulas
A formula is treated as an object within Writer and its default anchoring is As character within a
paragraph when it is inserted into a document. To change the anchoring of a formula object:
1) Right-click on the selected formula object and select Anchor from the context menu.
2) Select a new anchoring option from the context sub-menu. The anchoring positions
available are To page, To paragraph, To character, or As character.
3) Alternatively, right-click on the selected formula object and select Properties from the
context menu, or go to Format > Frame and Object > Properties on the main menu bar
to open the Object dialog (Figure 13).
4) Make sure the Type tab is selected and select a new anchoring position from the Anchor
section.
5) Click OK to save your changes and close the Object dialog.

Note
The anchoring options are not available in the Object dialog when you are making
changes to the various options available for frame styles. For more information on
how to modify frame styles, please refer to the chapters on styles in the Writer
Guide.
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Figure 13: Object dialog – Type tab with Anchor options

Vertical alignment
The normal default setting for vertical alignment for formula objects is to use the text base line as
a reference. This default setting can be changed by modifying the formula frame style, see the
chapters on styles in the Writer Guide for more information.
To change the vertical alignment position of an individual formula object:
1) Right-click on the selected formula object and select Properties from the context menu,
or go to Format > Frame and Object > Properties to open the Object dialog (Figure 13).
2) Make sure the Type tab is selected and select a new alignment position from the dropdown list in the Position section. The vertical alignment options available are Top,
Bottom, Center or From bottom.
3) If necessary, type in the text box a plus or minus value for vertical alignment. This option
is only available if From bottom vertical alignment has been selected.
4) Select the type of text alignment from the drop-down list in the Position section. The text
alignment options available are Base line, Character and Row.
5) Click OK to save your changes and close the Object dialog.

Note
If the Position section in the Object dialog is grayed out and not available, then go to
Tools > Options > LibreOffice Writer > Formatting Aids and uncheck the option Math
baseline alignment. This setting is stored with the document and applies to all
formulas within it. Any new documents created will also use this setting for Math
baseline alignment.
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Object spacing
A formula object, when inserted into a Writer document, has spacing in each side of the formula
object. The default value used for spacing is set within the frame style for formula objects and
can be changed by modifying the formula frame style, see the chapters on styles in the Writer
Guide for more information.
You can individually adjust the spacing for each formula object within your document as follows:
1) Create your formula in your Writer document.
2) Right-click on your selected formula object and select Properties from the context menu,
or go to Format > Frame and Object > Properties on the main menu bar to open the
Object dialog.
3) Click on the Wrap tab to open the Wrap page in the Object dialog (Figure 14).
4) In the Spacing section, enter the spacing value for Left, Right, Top and Bottom spacing.
5) Click OK to save your changes and close the Object dialog.

Figure 14: Object dialog – Wrap tab

Note
Object wrapping options will be grayed out if the object is anchored “As Character”.
To enable all wrapping options you need to anchor the object “To Page”, “To
Paragraph” or “To Character”. To change the anchor settings, right-click the formula
object and use the Anchor context menu to select the desired option.
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Text mode
In large formulas placed within a line of text, the formula elements can often be higher than the
text height. Therefore, to make large formulas easier to read, it is recommended to always insert
large formulas into a separate paragraph of their own so that it is separated from text.
However, if it is necessary to place a large formula within a line of text, double-click on the
formula to open the Formula Editor and then go to Format > Text Mode on the main menu bar.
The Formula Editor will try to shrink the formula to fit the text height. The numerators and
denominators of fractions are shrunk, and the limits of integrals and sums are placed beside the
integral/sum sign, as shown in the following example.

Example
A formula in a separate paragraph:
5

∑ i2
i=2

and the same formula embedded into a line of text using text mode format:

∑5i=2 i 2

Background and borders
The default setting for background (area fill) and borders for formula objects is set by the formula
frame style. To change this default setting for formula frame style, refer to the chapters on styles
in the Writer Guide. However, for individual formulas in your document, you can change the
background and borders.

Note
The size of the frame that a formula is placed in when inserted into a document
cannot be changed. The frame size for a formula object depends on the setting of
the formula font size, see Chapter 1 Creating & Editing Formulas for more
information.

Backgrounds
1) In your document, select the formula where you want to change the background.
2) Right-click on the formula and select Properties from the context menu, or go to Format
> Frame and Object > Properties on the main menu bar to open the object dialog.
3) Click on the Area tab and select the type of fill you want to use for your formula from the
Fill drop-down list (Figure 15).
4) Select the options you want to use for your formula background. The options change
depending on the type of fill selected.
5) Click OK to save your changes and close the Object dialog.
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Figure 15: Object dialog – Area tab

Borders
1) In your document, select the formula where you want to change the borders.
2) Right-click on the formula and select Properties from the context menu, or go to Format
> Frame and Object > Properties on the main menu bar to open the object dialog.
3) Click on the Borders tab and select the options you want to use for your formula borders
(Figure 16).
4) Click OK to save your changes and close the Object dialog.

Example
Below is an example of a formula using background color and borders.
n

∑ wi y i
i=1

Note that the background color and border properties are part of the Math OLE object and
hence cannot be defined using markup language.
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Figure 16: Object dialog – Borders tab

Quick insertion of formulas
To quickly insert a formula into your Writer document without opening the Formula Editor and you
know the markup language for the formula:
1) Enter the formula markup language into your document at the position where you want
the formula to be placed.
2) Select the markup language.
3) Go to Insert > Object on the main menu bar and select Formula to create a formula from
the selected markup language.
4) Alternatively you can use the key combination Ctrl + Insert to open the “Insert OLE
Object” dialog and then select Formula.
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Chapter 3
Formulas in Calc, Draw &
Impress

Introduction
In Calc, Draw, and Impress, formulas are inserted as OLE objects without any background (area
fill) or borders. See Chapter 1 Creating & Editing Formulas for more information on inserting
formulas into a LibreOffice module.
Each formula object is inserted into a spreadsheet, drawing, or slide as follows:
•

In Calc, formulas are inserted into a selected cell in a spreadsheet with no style assigned
to the formula object.

•

In Draw and Impress, formulas are inserted into a central position on your drawing or
slide and, by default, are assigned the drawing object style Object with no fill and no line.
For more information on how to modify or assign drawing object styles, see the Draw
User Guide or the Impress User Guide.

Anchoring formulas
Calc
A formula object can be anchored into your spreadsheet as To Page (default setting), or as To
Cell. To change the anchoring type of formulas in a Calc spreadsheet:
1) Select the formula object in your spreadsheet.
2) Right-click on the formula and select Anchor > To Page or To Cell from the context
menu
3) Alternatively, go to Format > Anchor on the main menu bar and select To Page or To
Cell.

Tip
If you insert a formula into a Calc spreadsheet and it appears out of scale, you can
fix it simply by right-clicking the formula object and then selecting the Original Size
option in the context menu.

Draw and Impress
When a formula is inserted into a drawing or slide, it is inserted as a floating OLE object and is
not anchored to any particular position in a drawing or slide.

Formula object properties
Formula objects in Calc, Draw, and Impress can be modified just like any other object that has
been placed in your spreadsheet, drawing, or presentation, with the exception of formula object
size and changing the format of any text within a formula. For more information on how to change
object properties, see the Calc User Guide, Draw User Guide and Impress User Guide. For more
information on formula object size and formatting formula text, see Chapter 1 Creating & Editing
Formulas in this guide.
The following points will help you select which dialog to use if you want to change the properties
of formula objects.
•

For formula backgrounds, use the various options in the tabs of the Area dialog.
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•

For formula borders, use the various options in the Line dialog. Note that formula borders
are separate from cell borders in a Calc spreadsheet.

•

To accurately re-position a formula object, use the various options in tabs of the Position
and Size dialog.

•

In Draw and Impress, you can arrange, align, group, flip, convert, break, combine, and
edit points of formula objects.

•

You cannot change the text attributes of a formula object. The text used in a formula is
set when you create the formula in the Formula Editor.

•

Formula object size is set by the formula font size when the formula is created in the
Formula Editor. The formula object size is protected in the Position and Size dialog, but
this can be deselected if you so wish. However, this is not recommended as resizing a
formula object using the Position and Size dialog could lead to distortion of a formula
making it difficult to read.

Formulas in charts
A chart in a Calc spreadsheet is itself an OLE object, therefore, you cannot use the Formula
Editor to create and insert a formula directly into a chart. However, you can create both the Chart
and Math objects separately and later copy and paste the Math formula into the Chart object:
1) Create the chart using LibreOffice Calc. For a complete reference on how to create charts
you should refer to the Calc Guide.
2) Click at any cell in your spreadsheet so that the Chart is no longer selected.
3) Insert a Math Formula object by clicking Insert > Object > Formula.
4) Type the desired formula into the Formula Editor.
5) After editing the formula, select the Math Formula object and press Ctrl + C to copy the
Formula object to the clipboard.
6) Double-click the chart object to start editing the chart and press Ctrl + V to paste the
Formula object into the chart.
7) Now you can position the object anywhere you want inside the chart.
Figure 17 shows an example of a Calc chart with a Math Formula object inside it, which in this
example is the sin(x ) function.
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Figure 17: Calc chart with a Math object inside it
If you want to change the formula at a later date, then you must repeat the whole process of
creating, copying, and pasting the Formula object into the chart.

Chemical formulas
The primary purpose of Math is to create mathematical formulas, but it can also be used to write
chemical formulas. However, in chemical formulas, the chemical symbols are normally written in
uppercase using non-italic characters. The following table shows some examples of chemical
formulas.
Construction

Example

Markup Language

Molecules

H 2 SO 4

H_2 SO_4

Isotopes

238
92

U lsub 92 lsup 238

Ions

SO 4

U
2−

or

2-

SO 4

SO_4^{2-{}} or SO_4^{2"-"}

To create chemical formulas using Math, you have to change the font used for variables to a nonitalic font. For more information on how to change fonts in a formula, see Chapter 1 Creating &
Editing Formulas.
For reversible reactions in chemical formulas, there is no symbol you can use for a double arrow
in Math. If you have a font available with correct symbols for use in chemical formulas, then you
can add these symbols to the Catalog. See “Catalog customization” on page 52 for more
information on how to add symbols to the Catalog.
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Chapter 4
Customization

Introduction
This chapter explains how you can customize LibreOffice Math to suit the way you create
formulas for use in LibreOffice documents. Also, refer to the Getting Started Guide for information
on how to customize LibreOffice.

Floating dialogs
The Formula Editor and Elements Dock can cover a large part of your document. To help create
more space and/or allow you to move either the Formula Editor or Elements Dock out of the way,
you can turn both of them into floating dialogs.
1) Position the cursor on the frame.
2) Hold down the Ctrl key and double-click. This turns the Formula Editor into the
Commands dialog (Figure 18) and the Elements Dock into the Elements Dock dialog
(Figure 19).

Figure 18: Commands dialog

Figure 19: Elements dialog
To return the Commands dialog and Elements Dock dialog back to their default positions:
1) Position the cursor on the frame of the dialog, NOT the title bar at the top of the of the
dialog.
2) Hold down the Ctrl key and double-click.

Adding keyboard shortcuts
You can add keyboard shortcuts to LibreOffice to make creating documents much easier and to
match your workflow. Below is an example of how to add a keyboard shortcut for inserting a Math
formula into a LibreOffice document.
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Note
When selecting new keyboards shortcuts, make sure that you do not select a
shortcut that is already in use by LibreOffice or your computer system. For example,
the keyboard combination Shift+Ctrl+F2 in Calc moves the cursor to the input line
where you can enter a Calc formula in the selected cell, NOT a Math formula.

Example keyboard shortcut
1) Go to Tools > Customize on the main menu bar to open the Customize dialog (Figure
20).
2) Click on the Keyboard tab to access the options available for adding keyboard shortcuts.

Figure 20: Customize dialog – Keyboard tab
3) Select the level of the new keyboard shortcut.
– Select LibreOffice if you want the new keyboard shortcut to be set for all modules of
LibreOffice.
– Select Math if you want the new keyboard shortcut to be set for Math only.
4) In the Category list, select Insert.
5) In the Function list, select Import Formula.
6) In the Shortcut Keys list, select the key or keyboard combination that you want to use for
your new keyboard shortcut.
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7) Click Modify and your keyboard shortcut will appear in the Keys list.
8) If necessary, continue to add keyboard shortcuts using the above steps.
Click OK to save your keyboard shortcuts and close the Customize dialog.

Tip
If you frequently add formulas into Writer documents you can set a shortcut to
quickly create Math Formulas. This can be done by following the steps described
above to assign a shortcut to the function “Formula” in the category “Insert”.
Beware that there are two different “Formula” commands available in the Customize
dialog in Writer and, although they have the same name, they correspond to different
LibreOffice commands. As shown in Figure 21, the first “Formula” command is used
to insert a Calculated Fields in Writer, whereas the second “Formula” is the one used
to insert new Math objects.

Figure 21: Assigning a shortcut to insert new Math objects

Keyboard customize options
The options for customizing keyboard shortcuts are as follows:
•

LibreOffice – displays shortcut keys that are common to all LibreOffice modules.

•

Math, Writer, Calc, Draw, or Impress – displays the keyboard shortcuts for the open
and current LibreOffice module.

•

Shortcut Keys – lists the shortcut keys and the associated commands. To assign or
modify the shortcut key for the command selected in the Function list, click a shortcut in
this list, and then click Modify.

•

Functions – type function name in the text field for search it in Function list.

•

Function – lists the function categories and the LibreOffice functions that you can assign
shortcut keys to.
– Category – lists the available function categories.
– Function – select a function that you want to assign a shortcut key to, select a key
combination in the Shortcut Keys list, and then click Modify. If the selected function
already has a shortcut key, it is displayed in the Keys list.
– Keys – displays the shortcut keys that are assigned to the selected function.

•

Modify – assigns the key combination selected in the Shortcut Keys list to the command
selected in the Function list.
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•

Delete – deletes the selected element or elements without requiring confirmation.

•

Load – replaces the shortcut key configuration with one that was previously saved.

•

Save – saves the current shortcut key configuration, so that you can load it later.

•

Reset – resets modified values back to the default values.

Catalog customization
If you regularly use a symbol that is not available in Math, you can add it to the Symbols dialog
(Figure 22) by opening the Edit Symbols dialog (Figure 23).
Using the Edit Symbols dialog you can add symbols to a symbol set, edit symbol sets, or modify
symbol notations. You can also define new symbol sets, assign names to symbols, or modify
existing symbol sets.

Adding symbols
1) Go to Tools > Symbols on the main menu bar or click on the Symbols icon
Tools toolbar to open the Symbols dialog.

in the

2) Click the Edit button to open Edit Symbols dialog.
3) Select a font from the Font drop-down list.
4) Select a symbol character that you want to add from the preview box. You may have to
scroll down in the preview box to locate the symbol you want to use. The right preview
box above the Add button displays the new symbol.
5) In the “Symbol” box, type a memorable name for the symbol you are adding.
6) In the “Symbol set” box, select a symbol set from the drop-down list to add your new
symbol to, or type a new name to create a new symbol set for your new symbol.
7) If required, select a font style from the “Style” drop-down list – Standard, Italic, Bold, or
Bold Italic.
8) Click Add, then click OK to close the Edit Symbols dialog. The new symbol and, if
created, new symbol set are now available for use.

Figure 22: Symbol dialog
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Figure 23: The Edit Symbols dialog

Note
When a new symbol is added to the catalog, you can type a percentage sign (%)
followed by the new name into the markup language in the Formula Editor and your
new symbol will appear in your formula. Remember that symbol names are case
sensitive, for example, %prime is a different symbol to %Prime.

Note
There are numerous free fonts available that contain several symbols if you cannot
find a symbol to use in the fonts already installed on your computer. For example,
the STIX font was developed specially for writing mathematical and technical texts.
Also, the DejaVu and Lucida fonts have a wide range of symbols that you can use.
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Note
When LibreOffice is installed on a computer, only those user-defined symbols that
actually occur in the document are stored with it. Sometimes it is useful to embed all
the user-defined symbols, so that when the document is transferred to another
computer it can be edited by another person. Go to Tools > Options > LibreOffice
Math > Settings and uncheck the option Embed only used symbols (smaller file
size).This setting is only available when you are working with LibreOffice Math.

Editing symbols
Modifying symbol names
You can change the name of a symbol as follows:
1) Select the symbol name you want to change from the “Old symbol” drop-down list. The
symbol appears in the left preview pane at the bottom of the Edit Symbols dialog (Figure
23).
2) Type a new name for the symbol in the Symbol: text box, or select a new name from the
“Symbol” drop-down list. The new symbol name appears above the right preview pane at
the bottom of the Edit Symbols dialog.
3) Click Modify and the symbol name is changed.
4) Click OK to close the Edit Symbols dialog.

Moving symbols
You can move a symbol from one symbol set to another as follows:
1) In the “Old symbol set” drop-down list, select the symbol set where the symbol you want
to move is located.
2) Select the symbol name you want move from the “Old symbol” drop-down list. The
symbol appears in the left preview pane at the bottom of the Edit Symbols dialog (Figure
23).
3) In the “Symbol set” drop-down list, select the symbol set that you want to move the
symbol to. The new symbol set name appears below the right preview pane at the bottom
of the Edit Symbols dialog.
4) Click Modify and the symbol is moved to the new symbol set.
5) Click OK to close the Edit Symbols dialog.

Deleting symbols
You can delete a symbol from a symbol set as follows:
1) In the “Old symbol set” drop-down list, select the symbol set from which you want to
delete the symbol.
2) Select the symbol name you want delete from the “Old symbol” drop-down list. The
symbol appears in the left preview pane at the bottom of the Edit Symbols dialog (Figure
23).
3) Click Delete and the symbol is deleted from the symbol set without any confirmation.
4) Click OK to close the Edit Symbols dialog.
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Note
The only way you can delete a symbol set is by deleting all of the symbols in that set.
When you delete the last symbol from a set, the set is also deleted.

Options for editing symbols
•

Old symbol – select the name of the current symbol. The symbol, the name of the
symbol, and the set that the symbol belongs to are displayed in the left preview pane at
the bottom of the Edit Symbols dialog.

•

Old symbol set – this list box contains the name of the current symbol set. You can also
select a different symbol set using this list box.

•

Symbol – lists the names for the symbols in the current symbol set. Select a name from
the list or type a name for a newly added symbol.

•

Symbol set – this list box contains the names of all existing symbol sets. You can modify
a symbol set or create a new one.

•

Font – displays the name of the current font and enables you to select a different font.

•

Subset – if you selected a non-symbol font in the Font list box, you can select a Unicode
subset in which to place your new or edited symbol. When a subset has been selected,
all symbols belonging to this subset of the current symbol set are displayed in the
Symbol list.

•

Style – the current style of font is displayed. You can change the font style by selecting
one from the list box.

•

Add – click this button to add the symbol shown in the right preview window to the
current symbol set. It will be saved under the name displayed in the Symbol list. You
must specify a name under Symbol or Symbol set to be able to use the Add button.
Names cannot be used more than once.

•

Modify – click this button to replace the name of the symbol shown in the left preview
window (the old name is displayed in the Old symbol list) with the new name you have
entered in the Symbol list.

•

Delete – click this button to remove the symbol shown in the left preview window from
the current symbol set. There will be confirmation of deletion. Deleting the last remaining
symbol of a symbol set also deletes the symbol set.

•

Cancel – click this button at any time to close the dialog without saving any of the
changes.

Formula spacing
The grave accent (`) inserts an additional small space and the tilde (~) inserts an additional large
space into formulas. However, in the basic installation of LibreOffice, these symbols are ignored
when they occur at the end of a formula. If you are working with running text in a formula, it may
be necessary to include spacing at the end of formulas as well. This customization is only
required when you are working with a Math document and is not required when you are inserting
a formula into another LibreOffice module.
To add spacing at the end of formula in Math, go to Tools > Options > LibreOffice Math >
Settings on the main menu bar and uncheck Ignore ~ and ` at the end of the line in the
Miscellaneous Options section.
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Note
To customize LibreOffice Math settings you need to start the LibreOffice Math
application and then navigate to Tools > Options > LibreOffice Math > Settings.
Read Formulas as separate documents or files to learn more about how to launch
LibreOffice Math.

Extensions
If you create formulas frequently in your documents, you can customize LibreOffice by adding
extensions that are designed to help you create formulas. Extensions are easily installed using
the Extension Manager. For more information on how to install extensions, see the Getting
Started Guide.
A commonly used extension is Formatting of All Math Formulas. It allows to format all Math
formulas in your Writer, Calc, Draw or Impress document. With it you can change the font names
and font sizes of all formulas in your document. For more information on this extension go to
https://extensions.libreoffice.org/extensions/formatting-of-all-math-formulas.
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Chapter 5
Exporting & Importing

MathML format
In addition to exporting documents as PDFs, as described in the Getting Started Guide,
LibreOffice offers the possibility of exporting formulas in the MathML format. This allows you or
another person to insert formulas into documents that were created in other software, for
example, Microsoft Office or an internet browser.

Note
Some internet browsers do not fully support the MathML format and your formula
may not display correctly.
If you are working on a Math document, go to File > Save as on the main menu bar or use the
keyboard combination Ctrl+Shift+S to open the Save as dialog. Select MathML from the list of
available file formats in File type: to save your formula as MathML.
If you are working in another LibreOffice module, right-click on the formula object and select
Save copy as from the context menu to open the Save as dialog. Select MathML from the list of
available file formats in “File type” to save your formula object as MathML.
In the Math you can import MathML formula also. Use main menu Tools > Import MathML from
clipboard for this.

Microsoft file formats
To control how formulas in Microsoft format are imported and exported using LibreOffice, go to
Tools > Options > Load/Save > Microsoft Office on the main menu bar and select or deselect
the options for MathType to LibreOffice Math or reverse.
•

[L]: Load and convert the object

•

[S]: Convert and save the object

[L]: Load and convert the object
Select this option if Microsoft OLE objects are to be converted into the specified LibreOffice OLE
object when a Microsoft document is opened in LibreOffice. For formulas, any embedded
MathType objects must not exceed the MathType 3.1 specifications to be successfully loaded
and converted. Information on MathType format can be found on the website
http://www.dessci.com/en.
If a document containing OMML formulas has been saved in .docx format and then converted to
the older .doc format, then any OMML objects are converted into graphics, which will be
displayed in LibreOffice as graphics.

[S]: Convert and save the object
Select this option if LibreOffice OLE objects are to be converted and saved in Microsoft file
format. LibreOffice converts any formulas into a format that can be read and modified by
Microsoft Equation Editor and MathType.
When this option is not selected, the formula is treated as an OLE object on conversion into
a .doc format and remains linked to LibreOffice. A double-click on the object in Microsoft Office
will attempt to launch LibreOffice.
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Commands Reference
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Introduction
This appendix lists all the operators and commands that are available for use in the Formula
Editor when you are creating your formulas.
The more common operators and commands can be entered by clicking on the appropriate icon
in the Elements Dock. Where there is no icon displayed in the following tables for the Elements
Dock, then you have to enter the operator or command into the Formula Editor using markup
language.

Note
In the markup language shown in the following tables, you have to replace the place
holder <?> with the value you want to use in your formulas.

Unary/binary operator commands
To access the icons used for entering markup language for unary/binary operator commands into
the Formula Editor, select Unary/Binary Operators from the drop-down list at the top of the
Elements Dock.
Operation

Markup language

Plus

+

+1

Minus

-

−1

Plus/minus

+- or plusminus

±1

Minus/plus

-+ or minusplus

∓1

Addition

<?> + <?>

A +B

Subtraction

<?> - <?>

A−B

Multiplication (Dot)

<?> cdot <?>

A⋅B

Multiplication

<?> times <?>

A×B

Multiplication (*)

<?> * <?>

A∗B

Division (Fraction)

{<?>} over {<?>}

A
B

Division

<?> div <?>

A÷B

Division (Slash)

<?> / <?> or <?> slash <?
>

A/B

Division (Wideslash)

{<?>} wideslash {<?>}
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Example formula

A
B

Operation

Markup language

Example formula

Division (Counter
Wideslash)

<?> widebslash <?>

Concatenate

<?> circ <?>

A∘B

Boolean NOT

neg <?>

¬A

Boolean AND

<?> and <?> or <?> & <?>

A∧B

Boolean OR

<?> or <?>

A∨B

Backslash

<?> bslash <?>

A ∖B

Slash in circle

<?> odivide <?>

A⊘B

Small multiply symbol in
circle

<?> odot <?>

A⊙B

Subtract symbol in circle

<?> ominus <?>

A⊖B

Add symbol in circle

<?> oplus <?>

A⊕B

Multiply symbol in circle

<?> otimes <?>

A⊗B

User defined binary
operator

<?> boper ????? <?>

A binOp B

User defined unary
operator

uoper ????? <?>

unOp B

B
A

Relation commands
To access the icons used for entering markup language for relations commands into the Formula
Editor, select Relations from the drop-down list at the top of the Elements Dock.
Operation

Markup language

Example formula

Is equal

<?> = <?>

A=B

Is not equal

<?> <> <?> or <?> neq <?>

A≠B

Is less than

<?> < <?> or <?> lt <?>

A <B

Is less than or equal to

<?> <= <?>

A≤B

Is less than or equal to

<?> leslant <?>

A⩽B

Is greater than

<?> > <?> or <?> gt <?>

A >B
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Operation

Markup language

Is greater than or equal to

<?> >= <?>

A≥B

Is greater than or equal to

<?> geslant <?>

A⩾B

Is much less than

<?> << <?> or <?> ll <?>

A ≪B

Is much greater than

<?> >> <?> or <?> gg <?>

A ≫B

Is approximately equal

<?> approx <?>

A≈B

Is similar to

<?> sim <?>

A∼B

Is similar to or equal

<?> simeq <?>

A≃B

Is congruent to

<?> equiv <?>

A≡B

Is proportional to

<?> prop <?>

A∝B

Is parallel to

<?> parallel <?>

A∥B

Is orthogonal to

<?> ortho <?>

A⊥B

Divides

<?> divides <?>

A∣B

Does not divide

<?> ndivides <?>

A ∤B

Toward

<?> toward <?>

A →B

Double arrow left

<?> dlarrow <?>

A⇐B

Double arrow left and right

<?> dlrarrow <?>

A⇔B

Double arrow right

<?> drarrow <?>

A ⇒B

Precedes

<?> prec <?>

A≺B

Succeeds

<?> succ <?>

A≻B

Precedes or equal to

<?> preccurlyeq <?>

A≼B

Succeeds or equal to

<?> succcurlyeq <?>

A≽B

Precedes or equivalent to

<?> precsim <?>

A≾B

Succeeds or equivalent to

<?> succsim <?>

A≿B

Not precedes

<?> nprec <?>

A⊀B

62 | LibreOffice Math Guide Version 7.0

Example formula

Operation

Markup language

Example formula

Not succeeds

<?> nsucc <?>

A⊁B

Definition

<?> def <?>

A≝B

Corresponding symbol
image of

<?> transl <?>

A⊷B

Corresponding symbol
original of

<?> transr <?>

A⊶B

Set operation commands
To access the icons used for entering markup language for set operation commands into the
Formula Editor, select Set Operations from the drop-down list at the top of the Elements Dock.
Operation

Markup language

Example formula

Is in

<?> in <?>

A ∈B

Is not in

<?> notin <?>

A ∉B

Owns

<?> owns <?> or <?> ni <?>

A∋B

Intersection

<?> intersection <?>

A∩B

Union

<?> union <?>

A∪B

Difference

<?> setminus <?> or
<?> bslash <?>

A ∖B

Quotient set (slash)
between characters

<?> slash <?>

A/B

Subset

<?> subset <?>

A⊂B

Subset or equal to

<?> subseteq <?>

A⊆B

Superset

<?> supset <?>

A⊃B

Superset or equal to

<?> supseteq <?>

A⊇B

Not subset

<?> nsubset <?>

A⊄B

Not subset or equal to

<?> nsubseteq <?>

A⊈B

Not superset

<?> nsupset <?>

A⊅B

Not superset or equal to

<?> nsupseteq <?>

A⊉B
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Operation

Markup language

Example formula

Empty set

emptyset

∅

Aleph (cardinal numbers)

aleph

ℵ

Natural numbers set

setN

ℕ

Integers set

setZ

ℤ

Set of rational numbers

setQ

ℚ

Real numbers set

setR

ℝ

Complex numbers set

setC

ℂ

Functions
To access the icons used for entering markup language for function commands into the Formula
Editor, select Functions from the drop-down list at the top of the Elements Dock.
Operation

Markup language

Absolute value

abs{<?>}

|A|

Factorial

fact{<?>}

A!

Square root

sqrt{<?>}

√A

Nth root

nroot{<?>}{<?>}

A

Power

<?>^{<?>}

A

Natural exponential function

func e^{<?>}

e

Natural logarithm

ln(<?>)

ln ( A)

Exponential function

exp(<?>)

exp( A)

Logarithm

log(<?>)

log( A)

Sine

sin(<?>)

sin( A)

Cosine

cos(<?>)

cos ( A)

Tangent

tan(<?>)

tan( A)

Cotangent

cot(<?>)

cot ( A)
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Example formula

√B
B

A

Operation

Markup language

Example formula

Hyperbolic sine

sinh(<?>)

sinh ( A)

Hyperbolic cosine

cosh(<?>)

cosh ( A)

Hyperbolic tangent

tanh(<?>)

tanh( A )

Hyperbolic cotangent

coth(<?>)

coth( A)

Inverse sine or arcsine

arcsin(<?>)

arcsin ( A)

Inverse cosine or arccosine

arccos(<?>)

arccos ( A)

Inverse tangent or
arctangent

arctan(<?>)

arctan ( A)

Inverse cotangent or
arccotangent

arccot(<?>)

arccot ( A )

Inverse or area hyperbolic
sine

arsinh(<?>)

arsinh ( A )

Inverse or area hyperbolic
cosine

arcosh(<?>)

arcosh ( A)

Inverse or area hyperbolic
tangent

artanh(<?>)

artanh ( A)

Inverse or area hyperbolic
cotangent

arcoth(<?>)

arcoth ( A)

Back epsilon

backepsilon

∍

Subscript

<?> sub <?>

AB

Operators
To access the icons used for entering markup language for operator commands into the Formula
Editor, select Operators from the drop-down list at the top of the Elements Dock.
Operation

Markup language

Example formula

Limes

lim <?>

lim A

Limes subscript bottom

lim from{<?>} <?>

lim B

Limes superscript top

lim to{<?>} <?>

lim B

A
A
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Operation

Markup language

Limes sup/sub script

lim from{<?>} to{<?>} <?>

Example formula
B

lim C
A

Limes inferior

liminf <?>

lim inf A

Limes superior

limsup <?>

lim sup A

Sum

sum <?>

∑a

Sum subscript bottom

sum from{<?>} <?>

∑B

Sum superscript top

sum to{<?>} <?>

Sum sup/sub script

sum from{<?>} to{<?>} <?>

A
A

∑B
B

∑C
A

Product

prod <?>

∏A

Product subscript bottom

prod from{<?>} <?>

∏B

Product superscript top

prod to{<?>} <?>

Product sup/sub script

prod from{<?>} to{<?>} <?>

A

A

∏B
B

∏C
A

Coproduct

coprod <?>

∐A

Coproduct subscript bottom

coprod from{<?>} <?>

∐B

Coproduct superscript top

coprod to{<?>} <?>

Coproduct sup/sub script

coprod from{<?>} to{<?>}
<?>

∐C

Integral

int <?>

∫A

Integral subscript bottom

int from{<?>} <?>

∫B

Integral superscript top

int to{<?>} <?>
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A

A

∐B
B
A

A
A

∫B

Operation

Markup language

Example formula
B

Integral sup/sub script

int from{<?>} to{<?>} <?>

∫C
A

Double integral

iint <?>

∬A

Double integral subscript
bottom

iint from{<?>} <?>

∬B

Double integral superscript
top

iint to{<?>} <?>

Double integral sup/sub
script

iint from{<?>} to{<?>} <?>

Triple integral

iiint <?>

∭A

Triple integral subscript
bottom

iiint from{<?>} <?>

∭B

Triple integral superscript
top

iiint to{<?>} <?>

Triple integral sup/sub
script

iiint from{<?>} to{<?>}
<?>

∭C

Curve integral

lint <?>

∮A

Curve integral subscript
bottom

lint from{<?>} <?>

∮B

Curve integral superscript
top

lint to{<?>} <?>

Curve integral sup/sub
script

lint from{<?>} to{<?>} <?>

Double curve integral

llint <?>

∯A

Double curve integral
subscript bottom

llint from{<?>} <?>

∯B

Double curve integral
superscript top

llint to{<?>} <?>

A
A

∬B
B

∬C
A

A
A

∭B
B

A

A
A

∮B
B

∮C
A

A
A

∯B
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Operation

Markup language

Example formula

Double curve integral
sup/sub script

llint from{<?>} to{<?>}
<?>

∯C

Triple curve integral

lllint <?>

∰A

Triple curve integral
subscript bottom

lllint from{<?>} <?>

∰B

Triple curve integral
superscript top

lllint to{<?>} <?>

Triple curve integral
sup/sub script

lllint from{<?>} to{<?>}
<?>

B

A

A
A

∰B
B

∰C
A

Note
For customized operators, use the command oper followed by your custom
operator. For example, entering oper OP from 0 to 1 A will give the formula
1

A
OP
0

.

Attributes
To access the icons used for entering markup language for attribute commands into the Formula
Editor, select Attributes from the drop-down list at the top of the Elements Dock, or click the
Attributes icon in the Elements dialog.
Operation

Markup language

Acute accent

acute <?>

Á

Grave accent

grave <?>

À

Breve

breve <?>

Ă

Circle

circle <?>

Å

Dot

dot <?>

Ȧ

Double dot

ddot <?>

Ä

Triple dot

dddot <?>

⃛
A

Line above

bar <?>

Ā
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Example formula

Operation

Markup language

Example formula

Vector arrow

vec <?>

⃗
A

Harpoon

harpoon <?>

⃑
A

Tilde

tilde <?>

~
A

Circumflex

hat <?>

A^

Reverse circumflex

check <?>

Ǎ

Large vector arrow

widevec {<?>}

⃗
AB

Large harpoon arrow

wideharpoon <?>

⃑
AB

Large tilde

widetilde {<?>}

~
AB

Large circumflex

widehat {<?>}

^
AB

Line over

overline {<?>}

AB

Line below

underline {<?>}

AB

Line through

overstrike {<?>}

AB

Transparent (blank
placeholder to create
space)

phantom {<?>}

A

Bold font

bold <?>

AB

Not bold font

nbold <?>

AB

Italic font

ital <?> or italic <?>

AB

Not italic font

nitalic <?>

AB

Resize

size <?> {<?>}

AB

Change font

font <?> {<?>}

AB

Color black

color black {<?>}

AB

Color blue

color blue {<?>}

AB

Color green

color green {<?>}

AB

Color red

color red {<?>}

AB

B

Appendix A Commands Reference | 69

Operation

Markup language

Example formula

Color cyan

color cyan {<?>}

AB

Color magenta

color magenta {<?>}

AB

Color yellow

color yellow {<?>}

AB

Color gray

color gray {<?>}

AB

Color lime

color lime {<?>}

AB

Color maroon

color maroon {<?>}

AB

Color navy

color navy {<?>}

AB

Color olive

color olive {<?>}

AB

Color purple

color purple {<?>}

AB

Color silver

color silver {<?>}

AB

Color teal

color teal {<?>}

AB

RGB colors

color rgb R G B {<?>}

AB

Note
The font command changes the font type The first placeholder is replaced with the
name of the font and the second placeholder is replaced with your formula values or
text. The default fonts you can use are Serif, Sans, or Fixed. If you have added
custom fonts to Math (see Chapter 1 Creating & Editing Formulas), then you can
replace the first placeholder with the custom font name.

Brackets
To access the icons used for entering markup language for bracket commands into the Formula
Editor, select Brackets from the drop-down list at the top of the Elements Dock.
Operation

Markup language

Group brackets (not
displayed in formula)

{<?>}

AB

Round brackets

(<?>)

( AB)

Left round bracket only

\(<?>

(A
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Example formula

Operation

Markup language

Example formula

Right round bracket only

<?>\)

A)

Square brackets

[<?>]

[ AB]

Left square bracket only

\[<?>

[A

Right square bracket only

<?>\]

A]

Double square brackets

ldbracket <?> rdbracket

⟦ AB⟧

Left double square bracket
only

\ldbracket <?>

⟦A

Right double square
bracket only

<?> \rdbracket

A⟧

Braces

lbrace <?> rbrace

{AB}

Left brace only

\lbrace <?>

{A

Right brace only

<?> \rbrace

A}

Angle brackets

langle <?> rangle

⟨ AB ⟩

Left angle bracket only

\langle <?>

⟨A

Right angle bracket only

<?> \rangle

A⟩

Operator brackets

langle <?> mline <?>
rangle

⟨ AB|CD ⟩

Ceiling (upper half square
brackets)

lceil <?> rceil

⌈ AB⌉

Left ceiling only

\lceil <?>

⌈A

Right ceiling only

<?> \rceil

A⌉

Floor (lower half square
brackets)

lfloor <?> rfloor

⌊ AB⌋

Left floor only

\lfloor <?>

⌊A

Right floor only

<?> \rfloor

A⌋

Single lines

lline <?> rline

|AB|

Left single line only

\lline <?>

|A
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Operation

Markup language

Right single line only

<?> \rline

A|

Double lines

ldline <?> rdline

‖AB‖

Left double line only

\ldline <?>

‖A

Right double line only

<?> \rdline

A‖

Scalable round brackets

left ( <?> right )

( BA )

Scalable left round bracket
only

left ( <?> right none

( BA

Scalable right round bracket
only

left none <?> right )

A
B

Scalable square brackets

left [ <?> right ]

Scalable left square bracket
only

left [ <?> right none

Scalable right square
bracket only

left none <?> right ]

Scalable double square
brackets

left ldbracket <?> right
rdbracket

Scalable left double square
bracket only

left ldbracket <?> right
none

Scalable right double
square bracket only

left none <?> right
rdbracket

Scalable braces

left lbrace <?> right
rbrace

Scalable left brace only

left lbrace {<?>} right
none

Scalable right brace only

left none {<?>} right
rbrace
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Example formula

)

A
B

[ ]
[
]
⟦ ⟧
⟦
⟧
{ }
{
}
A
B

A
B

A
B

A
B

A
B

A
B

A
B

A
B

Operation

Markup language

Example formula

Scalable angle brackets

left langle <?> right
rangle

⟨ ⟩

Scalable left angle bracket
only

left langle {<?>} right
none

⟨

Scalable right angle bracket
only

left none {<?>} right
rangle

A
B

Scalable operator brackets

left langle <?> mline <?>
right none

Scalable left operator
bracket

left langle <?> mline <?>
right none

Scalable right operator
bracket

left none <?> mline <?>
right rangle

Scalable ceiling (upper half
square brackets)

left lceil <?> right
rceil

Scalable left ceiling

left lceil <?> right none

Scalable right ceiling

left none <?> right rceil

Scalable floor (lower half
square brackets)

left lfloor <?> right
rfloor

Scalable left floor

left lfloor <?> right
none

Scalable right floor

left none <?> right
rfloor

Scalable single lines

left lline <?> right
rline

Scalable left single line

left lline <?> right none

Scalable right single line

left none <?> right rline

A
B

A
B

⟩
⟨| ⟩
⟨|
| ⟩
A C
B D
A C
B D

A C
B D
A
B

⌈ ⌉
⌈
⌉
⌊ ⌋
⌊
⌋
||
|
|
A
B

A
B

A
B

A
B

A
B

A
B

A
B

A
B
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Operation

Markup language

Example formula

Scalable double lines

left ldline <?> right
rdline

‖ BA ‖

Scalable left double line

left ldline <?> right
none

Scalable right double line

left none <?> right
rdline

‖ BA
A
B‖

Scalable top brace

{<?>} overbrace {<?>}

Scalable bottom brace

{<?>} underbrace {<?>}

D

⏞
ABC
ABC
⏟
D

Formats
To access the icons used for entering markup language for format commands into the Formula
Editor, select Formats from the drop-down list at the top of the Elements Dock.
Operation

Markup language

Power (superscript right)

<?>^{<?>} or <?>sup{<?>} or
<?>rsup{<?>}

20

Subscript right

<?>_{<?>} or <?>sub{<?>} or
<?>rsub{<?>}

2010

Superscript left

<?>lsup{<?>}

Subscript left

<?>lsub{<?>}

Superscript center

<?>csup{<?>}

20

Subscript center

<?>csub{<?>}

20

New line

newline

123
CD

Small gap

`

123 456

Blank or large gap

~

123 456

No space (suppresses
space between elements)

nospace {<?>}

12+4+5
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Example formula

10

10

20

20

10

10

10

Operation

Markup language

Example formula

Align left

alignl <?>

ABC
D

Align center

alignc <?>

ABC
D

Align right

alignr <?>

ABC
D

Vertical stack (2 elements)

binom{<?>}{<?>}

AB
12

Vertical stack (more than 2
elements)

stack{<?> # <?> # <?>}

AB
12
CD

Matrix stack

matrix{<?> # <?> ## <?> #
<?>}

AB 12
34 CD

Note
By default, text characters are aligned to the center in a formula. Use the alignl
and alignr commands to align text characters in a formula to the left or right when
a formula has more than one line. You can also use the align commands in
conjunction with the stack commands to align multi-line formulas on a specific
formula element, for example, the equals sign (=).

Others
To access the icons used for entering markup language for other commands into the Formula
Editor, select Others from the drop-down list at the top of the Elements Dock, or click the Others
icon in the Elements dialog.
Operation

Markup language

Example formula

Placeholder

<?>

Infinity

infinity or infty

∞

Partial derivative or set
margin

partial

∂

Nabla vector operator

nabla

∇

Existential quantifier, there
is at least one

exists

∃
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Operation

Markup language

Example formula

Existential quantifier, there
does not exist

notexists

∄

Universal quantifier, for all

forall

∀

H-bar constant

hbar

ℏ

Lambda bar

lambdabar

ƛ

Real part of a complex
number

re

ℜ

Imaginary part of a complex
number

im

ℑ

Weierstrass p function

wp

℘

Laplace transformation

laplace

ℒ

Left arrow

leftarrow

←

Right arrow

rightarrow

→

Up arrow

uparrow

↑

Down arrow

downarrow

↓

Ellipsis

dotslow

…

Math axis ellipsis

dotsaxis

⋯

Vertical ellipsis

dotsvert

⋮

Upward diagonal ellipsis

dotsup or dotsdiag

⋰

Downward diagonal ellipsis

dotsdown

⋱

Back epsilon

backepsilon

∍

Greek characters
Greek characters are normally entered into a formula using the Symbols dialog (see Chapter 1
Creating & Editing Formulas for more information). However, if you know the name of the Greek
character, you can type a percentage sign (%) followed by the name of the Greek character into
the Formula Editor.
For uppercase Greek characters, type the name using uppercase characters, for example
%BETA Β (see Table 3 for a full list of uppercase Greek characters). For lowercase Greek
characters, type the name using lowercase characters, for example %beta β (see Table 4 for a
full list of lowercase Greek characters)
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Italic Greek characters can also be entered into a formula by typing the character i after the
percentage sign (%) and before the name of the Greek character, for example, %iPI Π for
uppercase and %ipi for lowercase π . See Table 5 for a full list of italic uppercase Greek
characters and Table 6 for a full list of italic lowercase Greek characters.

Note
In localized versions of LibreOffice, the names of Greek characters are also
localized. If a document is not localized to the same language, then the names of
Greek characters in the following tables may not work correctly. If this happens, you
can use the Symbols dialog to select the required Greek character. When selected in
the Symbols dialog, the name of the Greek character is displayed at the bottom of
the Symbols dialog in the correct language. See Chapter 1 Creating & Editing
Formulas for more information on Greek characters and the Symbols dialog.
Table 3: Uppercase Greek characters
Α %BETA
%ALPHA

Β

%GAMMA

Γ

%DELTA

Δ

%EPSILON

Ε

%ZETA

Ζ

%ETA

Η

%THETA

Θ

%IOTA

Ι

%KAPPA

Κ

%LAMBDA

Λ

%MU

Μ

%NU

Ν

%XI

Ξ

%OMICRON

Ο

%PI

Π

%RHO

Ρ

%SIGMA

Σ

%TAU

Τ

%UPSILON

Υ

%PHI

Φ

%CHI

Χ

%PSI

Ψ

%OMEGA

Ω

β

%gamma

γ

%delta

δ

ε %zeta
ι %kappa

ζ
κ

%eta

η

%theta

θ

%lambda

%mu

μ

ν %xi
ρ %varsigma

ξ
ς

%omicron

λ
ο

%pi

π

%sigma

σ

%tau

τ

φ

%chi

χ

%psi

ψ

%omega

υ %varphi
ω %vartheta

%phi

ϕ

%varpi

ϖ

%varrho

ϱ %epsilon

ϑ
ϵ

Table 5: Uppercase italic Greek characters
Α %iBETA
%iALPHA

Β

%iGAMMA

Γ

%iDELTA

Δ

%iEPSILON

Ε

%iZETA

Ζ

%iETA

Η

%iTHETA

Θ

%iIOTA

Ι

%iKAPPA

Κ

%iLAMBDA

Λ

%iMU

Μ

%iNU

Ν

%iXI

Ξ

%iOMICRON

Ο

%iPI

Π

%iRHO

Ρ

%iSIGMA

Σ

%iTAU

Τ

%iUPSILON

Υ

%iPHI

Φ

%iCHI

Χ

%iPSI

Ψ

%iOMEGA

Ω

Table 4: Lowercase Greek characters
α %beta
%alpha
%varepsilon
%iota
%nu
%rho
%upsilon
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Table 6: Lowercase italic Greek characters
α %ibeta
%ialpha

β

%igamma

γ

%idelta

δ

%ivarepsil
on

ε

%izeta

ζ

%ieta

η

%itheta

θ

%iiota

ι

%ikappa

κ

%ilambda

%imu

μ

%inu

ν

%ixi

%iomicron

%ipi

π

%irho

ρ

%ivarsigma

ξ
ς

λ
ο

%isigma

σ

%itau

τ

%iupsilon

υ

%ivarphi

φ

%ichi

χ

%ipsi

%iomega

ω

%ivartheta

%iphi

ϕ

%ivarpi

%ivarrho

ϱ

%iepsilon

ϑ
ϵ

ψ
ϖ

Special characters
Special characters are normally entered into a formula using the Symbols dialog (see Chapter 1
Creating & Editing Formulas for more information). However, if you know the name of the special
character, you can type a percentage sign (%) followed by the name of the special character into
the Formula Editor. Table 7 Shows the full list of special characters that are available in
LibreOffice.

Note
In localized versions of LibreOffice, the names of special characters are also
localized. If a document is not localized to the same language, then the names of
special characters in the following table may not work correctly. If this happens, you
can use the Symbols dialog to select the required special character. When selected
in the Symbols dialog, the name of the special character is displayed at the bottom of
the Symbols dialog in the correct language. See Chapter 1 Creating & Editing
Formulas for more information on special characters and the Symbols dialog.
Table 7: Special characters
‰
%perthousand

%element

∈

%angle

∢

%noelement

∉

%infinite

→
∞

%and

∧

%or

∨

%notequal

≠

%identical

≡

%strictlylessthan

≪

%strictlygre
aterthan

≫

%tendto

Reserved words
A reserved word is a word that is used by LibreOffice as a command in the Math markup
language and it cannot be used as a variable name or entered into a formula as text. However, if
you want to use a reserved word as text in a formula then you must place the reserved word
between double quotes.
For example, consider that you want to use the word “purple” in a formula and you do not want
the formula elements to be changed to the color purple. If you simply type A purple B in the
Formula Editor, the resulting formula is A ¿ B , which is incorrect and the error is shown by the
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upside question mark. To correct this error, type A "purple" B in the Formula Editor using double
quotes each side of the word purple and the resulting correct formula is A purple B .
If you want the word “purple” written in italic, as you would normally have with variables, you can
type A italic{ "purple" } B in the formula editor, which will result in A purple B .
The reserved words used in Math are listed in the above tables for commands in markup
language.
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